Add patch to allow minimal porting for new libindicator - thanks to Evgeni Golov...
authorJulien Valroff <julien@kirya.net>
Sat, 25 Feb 2012 08:18:15 +0000 (09:18 +0100)
committerJulien Valroff <julien@kirya.net>
Sat, 25 Feb 2012 08:18:15 +0000 (09:18 +0100)
debian/changelog
debian/patches/014_libindicator-0.6.diff [new file with mode: 0644]
debian/patches/series

index c53165a..2a8368a 100644 (file)
@@ -1,3 +1,10 @@
+pino (0.2.11+dfsg-3) unstable; urgency=low
+
+  * Add patch to allow minimal porting for new libindicator - thanks to Evgeni
+    Golov <evgeni@debian.org> (Closes: #660775)
+
+ -- Julien Valroff <julien@debian.org>  Sat, 25 Feb 2012 09:17:10 +0100
+
 pino (0.2.11+dfsg-2) unstable; urgency=low
 
   * Add librsvg2-common to dependencies (Closes: #655217)
diff --git a/debian/patches/014_libindicator-0.6.diff b/debian/patches/014_libindicator-0.6.diff
new file mode 100644 (file)
index 0000000..b5e5334
--- /dev/null
@@ -0,0 +1,13 @@
+Index: pino-0.2.11+dfsg/CMakeLists.txt
+===================================================================
+--- pino-0.2.11+dfsg.orig/CMakeLists.txt       2012-02-21 19:51:37.342753639 +0100
++++ pino-0.2.11+dfsg/CMakeLists.txt    2012-02-21 19:52:57.695345902 +0100
+@@ -58,7 +58,7 @@
+ pkg_check_modules(WEBKIT REQUIRED "webkit-1.0 >= 1.0")
+ pkg_check_modules(LIBUNIQUE REQUIRED "unique-1.0 >= 1.0")
+ pkg_check_modules(GTKSPELL REQUIRED "gtkspell-2.0 >= 2.0")
+-pkg_check_modules(LIBINDICATE "indicate >= 0.3")
++pkg_check_modules(LIBINDICATE "indicate-0.6 >= 0.6")
+ pkg_check_modules(GTHREAD REQUIRED "gthread-2.0 >= 2.14.0")
+ set(pino_VALA_OPTIONS ${pino_VALA_OPTIONS} --thread)
index 8fdb429..94abd20 100644 (file)
@@ -5,3 +5,4 @@
 011_get_style_property-fix.diff
 012_libnotify-0.7.diff
 013_include-gthread.diff
+014_libindicator-0.6.diff