Fix previous commit
[debian/pino.git] / src / wscript
1 #!/usr/bin/env python
2
3 def build(bld):
4         prog = bld.new_task_gen(
5                 'cc', 'program',
6                 name = 'pino',
7                 target = 'pino',
8                 uselib = 'GTK+ GOBJECT LIBXML GEE LIBNOTIFY LIBSOUP WEBKIT GTHREAD LIBUNIQUE GTKSPELL',
9                 packages = 'gtk+-2.0 gee-1.0 gio-2.0 libnotify libsoup-2.4 libxml-2.0 webkit-1.0 config unique-1.0',
10                 ccflags = ['-include', 'config.h', '-DYAML_DECLARE_STATIC',],
11                 vapi_dirs = 'vapi/',
12                 source = bld.path.ant_glob(excl = 'oauth-client.vala', incl = 'vapi/*.c *.vala'),
13                 threading = True
14         )
15         if bld.env['HAVE_LIBINDICATE']:
16                 prog.env.append_value('VALAFLAGS', '-D LIBINDICATE')
17                 #prog.env.append_value('VALAFLAGS', '--disable-assert')
18                 prog.uselib += ' LIBINDICATE'
19
20         if bld.env['DEBUG']:
21                 prog.env.append_value('VALAFLAGS', '-D HAS_DEBUG')
22         if bld.env['UBUNTUICONS']:
23                 prog.env.append_value('VALAFLAGS', '-D HAS_UBUNTUICONS')
24         
25         prog.install_path = '${PREFIX}/bin'
26         prog.includes = 'vapi/'