Hopefully final fix
[debian/pino.git] / INSTALL
1 Requirements
2 =======================
3
4 To build Pino use next libraries and utilities:
5   * valac (>=0.7.10)
6   * gcc (>=4.2)
7   * intltool
8   * gettext
9   * gtk+-2.0
10   * libgee (>=0.5.0)
11   * gio-2.0
12   * libnotify
13   * libsoup-2.4
14   * libxml-2.0
15   * webkit-1.0
16   * libunique-1.0
17   * libgtkspell
18   * libindicate (optional)
19
20 You must install dev-packages for this libraries to build Pino.
21
22
23 Building with WAF
24 =======================
25
26 Pino uses a WAF build system. To build and install Pino use this commands:
27
28     ./waf configure --prefix=/usr
29     ./waf build
30     sudo ./waf install
31
32 For uninstalling type this:
33
34     sudo ./waf uninstall
35
36
37 Building with Cmake
38 =======================
39
40 Now you can build Pino with Cmake build system:
41
42     mkdir build
43     cd build
44     cmake ../ -DCMAKE_INSTALL_PREFIX=/usr -DUBUNTU_ICONS=OFF -DENABLE_DEBUG=OFF
45     make
46     sudo make install
47
48 For uninstalling type this:
49
50     sudo make uninstall